MongoDB의 취약한 인증을 통한 랜섬웨어 공격 주의
2017.01.31
□ 개요
 o 최근 오픈소스 기반 데이터베이스인 MongoDB의 취약한 인증을 악용한 랜섬웨어(금전 요구 등) 공격이 발견되어 사용자들의 주의 당부 및
    보안 설정 권고[1]
 
□ 주요 내용
 o 공격자는 MongoDB 관리용 포트(27107)의 인증 설정이 부재한 서버를 대상으로 DB 데이터를 백업 후 삭제하여 관리자에게 금전 요구
 o 전 세계적으로 MongoDB의 취약한 인증을 악용한 공격을 통해 2만7000여개 이상의 시스템 피해 발생
 
□ 영향받는 버전
 o MongoDB 3.2 이하 버전
    ※ 사용자 인증을 활성화 한 경우 영향 받지 않음
 
□ 대응 방안
 ① MongoDB 소프트웨어 최신버전 업데이트[2]
 ② 기존버전으로 사용 시 mongodb.conf 설정파일의 auth = true을 추가하여 사용자 인증 활성화
     ※ 기본 관리용 포트(27107) 변경 및 IP 접근제어 설정

□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
[1] MongoDB 공식 웹사이트, 랜섬웨어 대응 및 해결방안
   - https://www.mongodb.com/blog/post/how-to-avoid-a-malicious-attack-that-ransoms-your-dat
[2] MongoDB 최신버전 다운로드
   - https://www.mongodb.com/download-center?jmp=nav#community
랜섬패치다운로드
DOWNLOAD
랜섬패치 사용메뉴얼